View on GitHub

Compatibility Notes

ROpenCV should run on any platform which supports Ruby and OpenCV 2.4.4 or higher. It has been successfully tested on the following platforms.

  • Linux with Ruby 1.9.3 and OpenCV 2.4.4 - 2.4.6
  • Mac OSX with Ruby 1.9.3 and OpenCV 2.4.4 - 2.4.6

Installation

After running the following commands, ROpenCV and all the mandatory dependencies should be installed:

Ubuntu / Debian

Usage

require 'ropencv'
include OpenCV
m = cv::Mat.new(3,3,cv::CV_64FC1)